blob: 0db0f793d5cc8825b703b5ea030caec54e077aa3 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework"
2LICENSE = "LGPL-3.0"
3LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
4DEPENDS = "babl librsvg glib-2.0 gtk+ pango cairo expat zlib libpng jpeg virtual/libsdl json-glib intltool-native"
5
6EXTRA_OECONF = "--disable-docs"
7
Brad Bishop8410d612019-11-25 09:40:59 -05008inherit features_check gnomebase vala gobject-introspection
Brad Bishop316dfdd2018-06-25 12:45:53 -04009
10REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050011
12PACKAGECONFIG ??= ""
13PACKAGECONFIG[jasper] = "--with-jasper,--without-jasper,jasper"
14PACKAGECONFIG[avformat] = "--with-libavformat,--without-libavformat,libav"
15PACKAGECONFIG[lcms] = "--with-lcms,--without-lcms,lcms"
16PACKAGECONFIG[tiff] = "--with-libtiff,--without-libtiff,tiff"
17PACKAGECONFIG[webp] = "--with-webp,--without-webp,webp"
18
19SRC_URI = "http://ftp.gimp.org/pub/${BPN}/0.3/${BP}.tar.bz2 \
20 file://pkgconfig.patch "
21SRC_URI[md5sum] = "6e5c6f229261478dc436a38c84405b2a"
22SRC_URI[sha256sum] = "d7858ef26ede136d14e3de188a9e9c0de7707061a9fb96d7d615fab4958491fb"
23
24LDFLAGS += "-lm"
25
26# There are a couple of non-symlink .so files installed into libdir, which need to go into main package
27FILES_${PN}_append = " ${libdir}/gegl-0.3/*.so ${libdir}/gegl-0.3/*.json ${libdir}/libgegl-npd-0.3.so ${libdir}/libgegl-sc-0.3.so"
28FILES_${PN}-dev_append = " ${libdir}/gegl-0.3/*.la ${libdir}/libgegl-0.3.so"
29FILES_${PN}-dev_remove = "${libdir}/lib*.so"
30
31# Fails to build with thumb-1 (qemuarm)
32# gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process':
33# gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275
34ARM_INSTRUCTION_SET = "arm"