blob: 024534508cd98fb5bf3b16cc98bbd90a49142d95 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = " \
8 gdk-pixbuf-native \
9 intltool-native \
10 libxslt-native \
Brad Bishop26bdd442019-08-16 17:08:17 -040011 dbus-glib \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012 gtk+ \
13 babl \
14 gegl \
15 jpeg \
16 libpng \
17 libexif \
18 tiff \
19 lcms \
20 poppler \
21 jasper \
22 bzip2 \
23 libgudev \
24 libmng \
25"
26DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}"
27
Brad Bishop8410d612019-11-25 09:40:59 -050028inherit features_check gnomebase gtk-icon-cache gtk-doc
Brad Bishop316dfdd2018-06-25 12:45:53 -040029
30REQUIRED_DISTRO_FEATURES = "x11"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050031
32SRC_URI = "http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \
33 file://0001-configure-ac-do-not-check-for-freetype-config.patch \
34 file://bump_Babl-GEGL_versions.patch \
35 file://0003-Fix-use-of-gegl-API.patch \
36 "
37SRC_URI[md5sum] = "7e4fd7a53b1d3c32dff642ab1a94b44d"
38SRC_URI[sha256sum] = "9187a35cc52b110d78124d7b27b68a68ade14a794c2721314bac6134d2a5638a"
39
40EXTRA_OECONF = "--disable-python \
41 --without-webkit \
42 --without-wmf"
43
44do_configure_append() {
45 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
46 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
47}
48
49CFLAGS += "-fPIC"
50
51FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"
52FILES_${PN} += "${datadir}/appdata"