blob: 594899b0727a45171c91b7d001539e630db65cc9 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "ExtUtils::CppGuess - guess C++ compiler and flags"
2DESCRIPTION = "ExtUtils::CppGuess attempts to guess the system's C++ \
3compiler that is compatible with the C compiler that your perl was built \
4with. \
5It can generate the necessary options to the Module::Build constructor or \
6to ExtUtils::MakeMaker's WriteMakefile function."
7SECTION = "libs"
8
9HOMEPAGE = "http://search.cpan.org/~smueller/ExtUtils-CppGuess/"
10
11LICENSE = "Artistic-1.0 | GPL-1.0+"
12LIC_FILES_CHKSUM = "file://README;beginline=81;endline=84;md5=84c0390b90ea8c6702ce659b67bed699"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/E/ET/ETJ/ExtUtils-CppGuess-${PV}.tar.gz"
Brad Bishop8410d612019-11-25 09:40:59 -050015SRC_URI[md5sum] = "d6ddd5568c84f4c7b11b996b65f2ea3b"
16SRC_URI[sha256sum] = "12bf914708885265b5c3b0b8bfb0a9294cf132d5ca30d54bda0e00335fb43e61"
Brad Bishop316dfdd2018-06-25 12:45:53 -040017
18S = "${WORKDIR}/ExtUtils-CppGuess-${PV}"
19
20inherit cpan
21
22do_install () {
23 cpan_do_install
24}
25
26RDEPENDS_${PN} = " libcapture-tiny-perl \
27 perl-module-scalar-util \
28 perl-module-io-file \
29 perl-module-extutils-makemaker \
30 perl-module-file-spec \
31 perl-module-exporter \
32 perl-module-carp \
33 perl-module-file-temp \
34 perl-module-lib \
35"
36
37BBCLASSEXTEND = "native"