blob: 4f52ac70d07d09d89563ab42927886c4a2d3f65c [file] [log] [blame]
Brad Bishop0f291cc2019-09-01 15:16:57 -04001SUMMARY = "Python bindings for DBus AT-SPI2 accessibility"
2DESCRIPTION = "AT-SPI2 is a protocol over DBus, toolkit widgets use to provide content to screen readers such as Orca"
3SECTION = "devel/python"
4HOMEPAGE = "https://www.freedesktop.org/wiki/Accessibility/AT-SPI2/"
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e9f288ba982d60518f375b5898283886 \
7 file://COPYING.GPL;md5=751419260aa954499f7abaabaa882bbe"
8DEPENDS = "python3-dbus-native glib-2.0 dbus-glib libxml2 atk gtk+ python3-pygobject"
9
10SRC_URI = "git://github.com/GNOME/pyatspi2.git;protocol=https;branch=gnome-3-32"
11SRCREV = "dc4565208fca00da06b972915a080ad3c63f640d"
12S = "${WORKDIR}/git"
13
Brad Bishopc1d34332019-09-09 14:56:00 -040014# Same restriction as gtk+
Brad Bishop8410d612019-11-25 09:40:59 -050015inherit features_check
Brad Bishopc1d34332019-09-09 14:56:00 -040016ANY_OF_DISTRO_FEATURES = "${GTK2DISTROFEATURES}"
17
Brad Bishop0f291cc2019-09-01 15:16:57 -040018inherit pkgconfig autotools python3native
19
20FILES_${PN} += "${PYTHON_SITEPACKAGES_DIR}/pyatspi/*"