blob: 629881f0cfb597b173eb5e365557c8c949669db8 [file] [log] [blame]
Brad Bishop316dfdd2018-06-25 12:45:53 -04001SUMMARY = "JSON C++ lib used to read and write json file."
2DESCRIPTION = "Jsoncpp is an implementation of a JSON (http://json.org) reader \
3 and writer in C++. JSON (JavaScript Object Notation) is a \
4 lightweight data-interchange format. It is easy for humans to \
5 read and write. It is easy for machines to parse and generate."
6
7HOMEPAGE = "https://github.com/open-source-parsers/jsoncpp"
8
9SECTION = "libs"
10
Patrick Williams94a70a02020-12-01 11:48:33 -060011PE = "1"
12
Brad Bishop316dfdd2018-06-25 12:45:53 -040013LICENSE = "MIT"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=fa2a23dd1dc6c139f35105379d76df2b"
15
Brad Bishope42b3e32020-01-15 22:08:42 -050016SRCREV = "d2e6a971f4544c55b8e3b25cf96db266971b778f"
Patrick Williams23c9e5d2022-02-08 13:42:21 -060017SRC_URI = "git://github.com/open-source-parsers/jsoncpp;branch=master;protocol=https"
Brad Bishop316dfdd2018-06-25 12:45:53 -040018
19S = "${WORKDIR}/git"
20
21inherit cmake
22
23EXTRA_OECMAKE += "-DBUILD_SHARED_LIBS=ON -DJSONCPP_WITH_TESTS=OFF"
Brad Bishopc342db32019-05-15 21:57:59 -040024
25BBCLASSEXTEND = "native"