blob: 322497b09bb08456c909edee97e86b8d3c66581e [file] [log] [blame]
Patrick Williams8e7b46e2023-05-01 14:19:06 -05001SUMMARY = "A fast, pure Python library for parsing and serializing ASN.1 structures"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002HOMEPAGE = "https://github.com/wbond/asn1crypto"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=b5cda97fbd7959ad47a952651a87051a"
6
7PYPI_PACKAGE = "asn1crypto"
8
9SRC_URI[sha256sum] = "13ae38502be632115abf8a24cbe5f4da52e3b5231990aff31123c805306ccb9c"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN}:class-target += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060014 python3-codecs \
15 python3-crypt \
16 python3-ctypes \
17 python3-datetime \
18 python3-io \
19 python3-netclient \
20 python3-numbers \
21 python3-shell \
Andrew Geissler9aee5002022-03-30 16:27:02 +000022"
23
24BBCLASSEXTEND = "native nativesdk"