Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 1 | SUMMARY = "Build and publish crates with pyo3, rust-cpython, cffi bindings and rust binaries as python packages" |
| 2 | HOMEPAGE = "https://github.com/pyo3/maturin" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT | Apache-2.0" |
| 5 | LIC_FILES_CHKSUM = "file://license-apache;md5=1836efb2eb779966696f473ee8540542 \ |
| 6 | file://license-mit;md5=85fd3b67069cff784d98ebfc7d5c0797" |
| 7 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 8 | SRC_URI += "file://0001-Add-32-bit-RISC-V-support.patch" |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "ed12e1768094a7adeafc3a74ebdb8dc2201fa64c4e7e31f14cfc70378bf93790" |
| 10 | |
| 11 | S = "${WORKDIR}/maturin-${PV}" |
| 12 | |
| 13 | CFLAGS:append = " -fdebug-prefix-map=${CARGO_HOME}=${TARGET_DBGSRC_DIR}/cargo_home" |
| 14 | |
| 15 | DEPENDS += "\ |
| 16 | python3-setuptools-rust-native \ |
| 17 | python3-semantic-version-native \ |
| 18 | python3-setuptools-rust \ |
| 19 | " |
| 20 | |
| 21 | require ${BPN}-crates.inc |
| 22 | |
| 23 | inherit pypi cargo-update-recipe-crates python_pyo3 python_setuptools_build_meta |
| 24 | |
| 25 | do_configure() { |
| 26 | python_pyo3_do_configure |
| 27 | cargo_common_do_configure |
| 28 | python_pep517_do_configure |
| 29 | } |
| 30 | |
| 31 | RDEPENDS:${PN} += "\ |
| 32 | cargo \ |
| 33 | python3-json \ |
| 34 | rust \ |
| 35 | " |
| 36 | |
| 37 | RRECOMMENDS:${PN} += "\ |
| 38 | python3-ensurepip \ |
| 39 | python3-pip \ |
| 40 | python3-venv \ |
| 41 | " |
| 42 | |
| 43 | BBCLASSEXTEND = "native nativesdk" |