blob: 197bf91d6cc974817537e25c6c32f43d92aaca3d [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2HOMEPAGE = "https://pypi.org/project/ruamel.yaml/"
3
4LICENSE = "MIT"
Patrick Williamsb58112e2024-03-07 11:16:36 -06005LIC_FILES_CHKSUM = "file://LICENSE;md5=30cbbccd94bf3a2b0285ec35671a1938"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06006
7PYPI_PACKAGE = "ruamel.yaml"
8
9inherit pypi setuptools3
10
Patrick Williamsb58112e2024-03-07 11:16:36 -060011SRC_URI[sha256sum] = "8b27e6a217e786c6fbe5634d8f3f11bc63e0f80f6a5890f28863d9c45aac311b"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060012
13RDEPENDS:${PN} += "\
Patrick Williams73bd93f2024-02-20 08:07:48 -060014 python3-shell \
15 python3-datetime \
16 python3-netclient \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060017"
18
19do_install:prepend() {
20 export RUAMEL_NO_PIP_INSTALL_CHECK=1
21}
22
23BBCLASSEXTEND = "native nativesdk"