Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "Gstreamer validation tool" |
| 2 | DESCRIPTION = "A Tool to test GStreamer components" |
| 3 | HOMEPAGE = "https://gstreamer.freedesktop.org/documentation/gst-devtools/index.html" |
| 4 | SECTION = "multimedia" |
| 5 | |
| 6 | LICENSE = "LGPL-2.1-or-later" |
| 7 | LIC_FILES_CHKSUM = "file://validate/COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343" |
| 8 | |
| 9 | #S = "${WORKDIR}/gst-devtools-${PV}" |
| 10 | |
| 11 | SRC_URI = "https://gstreamer.freedesktop.org/src/gst-devtools/gst-devtools-${PV}.tar.xz \ |
| 12 | file://0001-connect-has-a-different-signature-on-musl.patch \ |
| 13 | " |
| 14 | |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "0e1ec0d0b8f2d3d314a397399cd01dfc50c02ac088176996f934758119075ea9" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 16 | |
| 17 | DEPENDS = "json-glib glib-2.0 glib-2.0-native gstreamer1.0 gstreamer1.0-plugins-base" |
| 18 | RRECOMMENDS:${PN} = "git" |
| 19 | |
| 20 | FILES:${PN} += "${datadir}/gstreamer-1.0/* ${libdir}/gst-validate-launcher/* ${libdir}/gstreamer-1.0/*" |
| 21 | |
| 22 | inherit meson pkgconfig gettext upstream-version-is-even gobject-introspection |
| 23 | |
| 24 | # TODO: put this in a gettext.bbclass patch |
| 25 | def gettext_oemeson(d): |
| 26 | if d.getVar('USE_NLS') == 'no': |
| 27 | return '-Dnls=disabled' |
| 28 | # Remove the NLS bits if USE_NLS is no or INHIBIT_DEFAULT_DEPS is set |
| 29 | if d.getVar('INHIBIT_DEFAULT_DEPS') and not oe.utils.inherits(d, 'cross-canadian'): |
| 30 | return '-Dnls=disabled' |
| 31 | return '-Dnls=enabled' |
| 32 | |
| 33 | # Build GstValidateVideo |
| 34 | PACKAGECONFIG[cairo] = "-Dcairo=enabled,-Dcairo=disabled,cairo" |
| 35 | |
| 36 | EXTRA_OEMESON += " \ |
| 37 | -Ddoc=disabled \ |
| 38 | -Ddebug_viewer=disabled \ |
| 39 | -Dtests=disabled \ |
| 40 | -Dvalidate=enabled \ |
| 41 | ${@gettext_oemeson(d)} \ |
| 42 | " |
| 43 | |
| 44 | do_install:append () { |
| 45 | for fn in ${bindir}/gst-validate-launcher \ |
| 46 | ${libdir}/gst-validate-launcher/python/launcher/config.py; do |
| 47 | sed -i -e 's,${B},/usr/src/debug/${PN},g' -e 's,${S},/usr/src/debug/${PN},g' ${D}$fn |
| 48 | done |
| 49 | } |
| 50 | |
| 51 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 52 | GIR_MESON_DISABLE_FLAG = "disabled" |