blob: 7c0bfed52e99abc8fc2ec65f0ca9d279488ca5f5 [file] [log] [blame]
Adriana Kobylakb02da7b2016-10-19 14:58:25 -05001SUMMARY = "Logging DBUS Object"
2DESCRIPTION = "Logging DBUS Object"
3HOMEPAGE = "https://github.com/openbmc/phosphor-logging"
4PR = "r1"
5
6inherit autotools pkgconfig
7inherit pythonnative
8inherit obmc-phosphor-license
9inherit obmc-phosphor-dbus-service
10
11DBUS_SERVICE_${PN} += "xyz.openbmc_project.Logging.service"
12
13DEPENDS += "autoconf-archive-native"
14DEPENDS += "systemd"
15DEPENDS += "python-mako-native"
16DEPENDS += "python-pyyaml-native"
Patrick Williams845123d2016-12-09 08:56:38 -060017DEPENDS += "sdbusplus sdbusplus-native"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050018PROVIDES += "virtual/obmc-logging-mgmt"
19RPROVIDES_${PN} += "virtual-obmc-logging-mgmt"
20
21SRC_URI += "git://github.com/openbmc/phosphor-logging"
Patrick Williamsfd911cb2016-12-08 11:50:03 -060022SRCREV = "8f7941edf6843109d3da69900976b04b42d78aa4"
Adriana Kobylakb02da7b2016-10-19 14:58:25 -050023
24S = "${WORKDIR}/git"
25