blob: 124454ab75e74b0cb29a6ff7a7f746a093ebb8e0 [file] [log] [blame]
Brad Bishop286d45c2018-10-02 15:21:57 -04001
2# enable the overrides for the context of the conf only
3OVERRIDES .= ":qemuboot-xilinx"
4
Brad Bishop286d45c2018-10-02 15:21:57 -04005# Default machine targets for Xilinx QEMU (FDT Generic)
6QB_MACHINE_aarch64 = "-machine arm-generic-fdt"
7QB_MACHINE_arm = "-machine arm-generic-fdt-7series"
8QB_MACHINE_microblaze = "-machine microblaze-generic-fdt-plnx"
9
10# defaults
11QB_DEFAULT_KERNEL ?= "none"
12
13inherit qemuboot
14
15# rewrite the qemuboot with the custom sysroot bindir
16python do_write_qemuboot_conf_append() {
17 val = os.path.join(d.getVar('BASE_WORKDIR'), d.getVar('BUILD_SYS'), 'qemu-xilinx-helper-native/1.0-r1/recipe-sysroot-native/usr/bin/')
18 cf.set('config_bsp', 'STAGING_BINDIR_NATIVE', '%s' % val)
19
20 # write out the updated version from this append
21 with open(qemuboot, 'w') as f:
22 cf.write(f)
23}
24