blob: 08e356d43c0d406b4616747d986e7086d559b114 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001SUMMARY = "Device Tree Compiler"
2HOMEPAGE = "https://devicetree.org/"
3DESCRIPTION = "The Device Tree Compiler is a tool used to manipulate the Open-Firmware-like device tree used by PowerPC kernels."
4SECTION = "bootloader"
5LICENSE = "GPLv2 | BSD"
6DEPENDS = "flex-native bison-native swig-native"
7
8SRC_URI = "git://git.kernel.org/pub/scm/utils/dtc/dtc.git"
9
10UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
11
12LIC_FILES_CHKSUM = "file://libfdt.i;beginline=1;endline=6;md5=afda088c974174a29108c8d80b5dce90"
13
14SRCREV = "60e0db3d65a1218b0d5a29474e769f28a18e3ca6"
15
16S = "${WORKDIR}/git/pylibfdt"
17
18DEPENDS += "libyaml dtc"
19
20inherit distutils3
21
22do_configure_prepend() {
23 (cd ${S}/../ ; make version_gen.h )
24}
25
26BBCLASSEXTEND = "native nativesdk"
27