blob: 6d50c234791a4b1be2cc0eff4e9f0415a15de904 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "Xilinx Runtime(XRT) libraries"
2DESCRIPTION = "Xilinx Runtime User Space Libraries and headers"
3
4LICENSE = "GPLv2 & Apache-2.0"
Andrew Geissler84ad7c52020-06-27 00:00:16 -05005LIC_FILES_CHKSUM = "file://../LICENSE;md5=da5408f748bce8a9851dac18e66f4bcf \
6 file://runtime_src/core/edge/drm/zocl/LICENSE;md5=7d040f51aae6ac6208de74e88a3795f8 \
7 file://runtime_src/core/pcie/driver/linux/xocl/LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://runtime_src/core/pcie/linux/LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57 \
9 file://runtime_src/core/pcie/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 \
10 file://runtime_src/core/edge/tools/xbutil/LICENSE;md5=d273d63619c9aeaf15cdaf76422c4f87 "
Brad Bishop26bdd442019-08-16 17:08:17 -040011
Andrew Geissler84ad7c52020-06-27 00:00:16 -050012BRANCH ?= "2020.1"
13REPO ?= "git://github.com/Xilinx/XRT.git;protocol=https"
14BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}"
15SRC_URI = "${REPO};${BRANCHARG}"
Brad Bishop26bdd442019-08-16 17:08:17 -040016
Andrew Geissler84ad7c52020-06-27 00:00:16 -050017PV = "202010.2.6.0"
18SRCREV ?= "2d6bfe4ce91051d4e5b499d38fc493586dd4859a"
Brad Bishop26bdd442019-08-16 17:08:17 -040019
20S = "${WORKDIR}/git/src"
21
22inherit cmake
23
24BBCLASSEXTEND = "native nativesdk"
25
26# util-linux is for libuuid-dev.
Andrew Geissler84ad7c52020-06-27 00:00:16 -050027DEPENDS = "libdrm opencl-headers ocl-icd opencl-clhpp boost util-linux git-replacement-native protobuf-native protobuf"
Brad Bishop26bdd442019-08-16 17:08:17 -040028RDEPENDS_${PN} = "bash ocl-icd boost-system boost-filesystem"
29
30EXTRA_OECMAKE += " \
31 -DCMAKE_BUILD_TYPE=Release \
32 -DCMAKE_EXPORT_COMPILE_COMANDS=ON \
33 "
Andrew Geissler84ad7c52020-06-27 00:00:16 -050034
35EXTRA_OECMAKE_append_versal += "-DXRT_AIE_BUILD=true"
36TARGET_CXXFLAGS_append_versal += "-DXRT_ENABLE_AIE"
37DEPENDS_append_versal += " libmetal libxaiengine"
38RDEPENDS_${PN}_append_versal += " libxaiengine"
39
40pkg_postinst_ontarget_${PN}() {
41 #!/bin/sh
42 if [ ! -e /etc/OpenCL/vendors/xilinx.icd ]; then
43 echo "INFO: Creating ICD entry for Xilinx Platform"
44 mkdir -p /etc/OpenCL/vendors
45 echo "libxilinxopencl.so" > /etc/OpenCL/vendors/xilinx.icd
46 chmod -R 755 /etc/OpenCL
47 fi
48}