blob: 391f388e4b7f51751429b415953e2493300b3552 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001inherit esw deploy python3native
2
3DEPENDS += "dtc-native python3-dtc-native python3-pyyaml-native xilstandalone libxil xiltimer device-tree"
4
5do_configure_prepend() {
6 cd ${S}
7 nativepython3 ${S}/scripts/linker_gen.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH}
8}
9
10do_generate_eglist () {
11 cd ${S}
12 nativepython3 ${S}/scripts/example.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH}
13}
14addtask generate_eglist before do_configure after do_prepare_recipe_sysroot
15do_prepare_recipe_sysroot[rdeptask] = "do_unpack"
16
17do_install() {
18 install -d ${D}/${base_libdir}/firmware
19 install -m 0755 ${B}/*.elf ${D}/${base_libdir}/firmware
20}
21
22do_deploy() {
23 install -Dm 0644 ${WORKDIR}/package/${base_libdir}/firmware/*.elf ${DEPLOYDIR}/
24}
25addtask deploy before do_build after do_package
26
27FILES_${PN} = "${base_libdir}/firmware/*.elf"