blob: 152348486023b316448949d6a05ddeb926e24dc9 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001require gcc-configure-xilinx-standalone.inc
2require gcc-xilinx-standalone.inc
3
4# We want to use the stock multilib configs, when available
5EXTRACONFFUNCS_xilinx-standalone = ""
6
7EXTRA_OECONF_append_xilinx-standalone = " \
8 --enable-multilib \
9"
10
11# Temporary hack to build gcc cross canadian for tclibc-newlib as --with-sysroot=/not/exist
12# has been removed from TARGET_OS for elf and eabi in gcc-cross-canadian.inc
13
14python() {
15 if 'xilinx-standalone' in d.getVar("DISTROOVERRIDES").split(':'):
16 extraoeconfgcc = d.getVar('EXTRA_OECONF')
17 extraoeconfgcc += " --with-sysroot=/not/exist"
18 d.delVar('EXTRA_OECONF')
19 d.setVar('EXTRA_OECONF', extraoeconfgcc)
20}