blob: e80b0b79f467e98f943475b1013deda9caea2b2c [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001require gcc-configure-xilinx-standalone.inc
2
3COMPATIBLE_HOST = "${HOST_SYS}"
4
5python do_multilib_install_xilinx-standalone_class-target () {
6 pass
7}
8
9standalone_fixup () {
10 (
11 cd ${D}${libdir}
12 for each in ${TARGET_SYS}/*/* ; do
13 ln -s $each $(basename $each)
14 done
15 )
16}
17
18FIXUP_FUNCTION = ""
19FIXUP_FUNCTION_xilinx-standalone_class-target = " standalone_fixup"
20
21do_install[postfuncs] .= "${FIXUP_FUNCTION}"
22
23FILES_${PN}-dev_append_xilinx-standalone_class-target = " \
24 ${libdir}/*.a \
25 ${libdir}/*.o \
26"