blob: a4a393c377b59c953197a2a0c172f67754241770 [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001inherit esw python3native
2
3ESW_COMPONENT_SRC = "/lib/bsp/standalone/src/"
4ESW_COMPONENT_NAME = "libxilstandalone.a"
5
6DEPENDS += "dtc-native python3-dtc-native python3-pyyaml-native libgloss device-tree"
7
8do_configure_prepend() {
9 # This script should also not rely on relative paths and such
10 cd ${S}
11 nativepython3 ${S}/scripts/generate_libdata.py -d ${DTBFILE}
12}