blob: 428fa6869c252839c92d08b51fe0c77ba4bda11e [file] [log] [blame]
Andrew Geissler84ad7c52020-06-27 00:00:16 -05001inherit esw python3native
2
3ESW_COMPONENT_SRC = "/lib/sw_services/xiltimer/src/"
4ESW_COMPONENT_NAME = "libxiltimer.a"
5
6DEPENDS += "dtc-native python3-dtc-native python3-pyyaml-native libxil device-tree"
7
8do_configure_prepend() {
9 # This script should also not rely on relative paths and such
10 cd ${S}
11 nativepython3 ${S}/scripts/lib_parser.py -d ${DTBFILE} -o ${OECMAKE_SOURCEPATH}
12}