Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | require gdb.inc |
| 2 | require gdb-${PV}.inc |
| 3 | |
| 4 | inherit python3-dir |
| 5 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 6 | EXTRA_OEMAKE:append:libc-musl = "\ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 7 | gt_cv_func_gnugettext1_libc=yes \ |
| 8 | gt_cv_func_gnugettext2_libc=yes \ |
| 9 | gl_cv_func_working_strerror=yes \ |
| 10 | gl_cv_func_strerror_0_works=yes \ |
| 11 | gl_cv_func_gettimeofday_clobber=no \ |
| 12 | " |
| 13 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 14 | do_configure:prepend() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 15 | if [ "${@bb.utils.filter('PACKAGECONFIG', 'python', d)}" ]; then |
| 16 | cat > ${WORKDIR}/python << EOF |
| 17 | #!/bin/sh |
| 18 | case "\$2" in |
| 19 | --includes) echo "-I${STAGING_INCDIR}/${PYTHON_DIR}${PYTHON_ABI}/" ;; |
| 20 | --ldflags) echo "-Wl,-rpath-link,${STAGING_LIBDIR}/.. -Wl,-rpath,${libdir}/.. -lpthread -ldl -lutil -lm -lpython${PYTHON_BASEVERSION}${PYTHON_ABI}" ;; |
| 21 | --exec-prefix) echo "${exec_prefix}" ;; |
| 22 | *) exit 1 ;; |
| 23 | esac |
| 24 | exit 0 |
| 25 | EOF |
| 26 | chmod +x ${WORKDIR}/python |
| 27 | fi |
| 28 | } |