blob: 8e370f962ced3451bc3e6fe2543e3b29f6f34dc1 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "Proxy for UDP/TCP debug connections"
2DESCRIPTION = "The agent-proxy will forward tcp or udp connections as well as allow for script multiplexing of terminal sessions."
3HOMEPAGE = "http://kgdb.wiki.kernel.org/"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
6
7SECTION = "devel"
8
9EXTRA_OEMAKE = "'CC=${CC}'"
10
11SRCREV = "e6c9d3d996bd55e7ab14dbd74deb7841e0c3a4f1"
12PV = "1.96+git${SRCPV}"
13
14SRC_URI = "git://git.kernel.org/pub/scm/utils/kernel/kgdb/agent-proxy.git;protocol=git \
15 file://0001-Makefile-Add-LDFLAGS-variable.patch \
16"
17
18BBCLASSEXTEND = "native nativesdk"
19
20S = "${WORKDIR}/git"
21
22do_install () {
23 install -d ${D}${bindir}
24 install -m 0755 agent-proxy ${D}${bindir}
25}