blob: c1db04a9e707431d3c40783dd7b9d398fd0bfc1c [file] [log] [blame]
Vijay Khemka4809bd12019-12-16 17:48:02 -08001SUMMARY = "Phosphor post code manager"
2DESCRIPTION = "Phosphor post Code Manager monitors post code posted on dbus \
3interface /xyz/openbmc_project/state/boot/raw by snoopd daemon and save them \
4in a file under /var/lib for history."
5
6SRC_URI = "git://github.com/openbmc/phosphor-post-code-manager.git"
Andrew Geissler85c358c2021-02-25 21:01:34 +00007SRCREV = "08125ca77fde5a8d6bfefcdacd1d96cbb3bd7e9c"
Vijay Khemka4809bd12019-12-16 17:48:02 -08008
9S = "${WORKDIR}/git"
10
11PV = "1.0+git${SRCPV}"
12
13LICENSE = "Apache-2.0"
14LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
15
16inherit cmake pkgconfig systemd
17
Kumar Thangavel27cb8232020-09-01 23:05:19 +053018
19def get_service(d):
20 if(d.getVar('OBMC_HOST_INSTANCES') == '0'):
21 return "xyz.openbmc_project.State.Boot.PostCode.service"
22 else:
23 return " ".join(["xyz.openbmc_project.State.Boot.PostCode@{}.service".format(x) for x in d.getVar('OBMC_HOST_INSTANCES').split()])
24
25SYSTEMD_SERVICE_${PN} = "${@get_service(d)}"
Vijay Khemka4809bd12019-12-16 17:48:02 -080026
27DEPENDS += " \
28 sdbusplus \
29 phosphor-dbus-interfaces \
30 phosphor-logging \
31 "
Kumar Thangavel27cb8232020-09-01 23:05:19 +053032
33FILES_${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode@.service"
34FILES_${PN} += "${systemd_system_unitdir}/xyz.openbmc_project.State.Boot.PostCode.service"