Chanh Nguyen | 2fc68eb | 2022-04-28 09:11:28 +0000 | [diff] [blame] | 1 | SUMMARY = "Phosphor OpenBMC Platform Init Service" |
| 2 | DESCRIPTION = "Phosphor OpenBMC Platform Init Daemon" |
| 3 | |
| 4 | PR = "r1" |
| 5 | LICENSE = "Apache-2.0" |
| 6 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
| 7 | |
| 8 | inherit systemd |
| 9 | inherit obmc-phosphor-systemd |
| 10 | |
| 11 | DEPENDS += "systemd" |
| 12 | RDEPENDS:${PN} += "libsystemd" |
| 13 | RDEPENDS:${PN} += "bash" |
| 14 | |
| 15 | SRC_URI = " \ |
| 16 | file://ampere-platform-init.service \ |
| 17 | file://ampere-bmc-heartbeat.service \ |
| 18 | file://ampere_platform_init.sh \ |
| 19 | file://ampere_bmc_heartbeat.sh \ |
| 20 | file://${MACHINE}_platform_gpios_init.sh \ |
| 21 | file://gpio-lib.sh \ |
Chau Ly | b10e6e7 | 2023-04-13 04:40:02 +0000 | [diff] [blame] | 22 | file://ampere_uart_console_setup.sh \ |
| 23 | file://ampere_uartmux_ctrl.sh \ |
Chanh Nguyen | 2fc68eb | 2022-04-28 09:11:28 +0000 | [diff] [blame] | 24 | " |
| 25 | SYSTEMD_PACKAGES = "${PN}" |
| 26 | SYSTEMD_SERVICE:${PN} = "ampere-platform-init.service ampere-bmc-heartbeat.service" |
| 27 | |
| 28 | do_install () { |
| 29 | install -d ${D}${sbindir} |
| 30 | install -m 0755 ${WORKDIR}/gpio-lib.sh ${D}${sbindir}/ |
| 31 | install -m 0755 ${WORKDIR}/ampere_platform_init.sh ${D}${sbindir}/ |
| 32 | install -m 0755 ${WORKDIR}/ampere_bmc_heartbeat.sh ${D}${sbindir}/ |
| 33 | install -m 0755 ${WORKDIR}/${MACHINE}_platform_gpios_init.sh ${D}${sbindir}/platform_gpios_init.sh |
Chau Ly | b10e6e7 | 2023-04-13 04:40:02 +0000 | [diff] [blame] | 34 | install -m 0755 ${WORKDIR}/ampere_uart_console_setup.sh ${D}${sbindir}/ |
| 35 | install -m 0755 ${WORKDIR}/ampere_uartmux_ctrl.sh ${D}/${sbindir}/ |
Chanh Nguyen | 2fc68eb | 2022-04-28 09:11:28 +0000 | [diff] [blame] | 36 | install -d ${D}${systemd_unitdir}/system/ |
| 37 | install -m 0644 ${WORKDIR}/ampere-platform-init.service ${D}${systemd_unitdir}/system |
| 38 | } |
| 39 | |