blob: 601056b7e58d25741549d50cf49bba54e39d2b2e [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001# Simple initramfs image. Mostly used for live images.
2DESCRIPTION = "Small image capable of booting a device. The kernel includes \
3the Minimal RAM-based Initial Root Filesystem (initramfs), which one can use \
4to check the hardware efficiently."
5
6PACKAGE_INSTALL = "initramfs-debug busybox base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
7
8# Do not pollute the initrd image with rootfs features
9IMAGE_FEATURES = ""
10
11export IMAGE_BASENAME = "initramfs-debug-image"
12IMAGE_LINGUAS = ""
13
Andrew Geissler69721092021-07-23 12:57:00 -040014# Some BSPs use IMAGE_FSTYPES_<machine override> which would override
15# an assignment to IMAGE_FSTYPES so we need anon python
16python () {
17 d.setVar("IMAGE_FSTYPES", d.getVar("INITRAMFS_FSTYPES"))
18}
19
Andrew Geissler82c905d2020-04-13 13:39:40 -050020inherit core-image
21
22IMAGE_ROOTFS_SIZE = "8192"
23IMAGE_ROOTFS_EXTRA_SPACE = "0"
24
25BAD_RECOMMENDATIONS += "busybox-syslog"