blob: 7e6e03d8e7da008b48c22365101127c947207c33 [file] [log] [blame]
Patrick Williamsb48b7b42016-08-17 15:04:38 -05001SUMMARY = "Initramfs image for kexecboot kernel"
2DESCRIPTION = "This image provides kexecboot (linux as bootloader) and helpers."
Patrick Williamsb48b7b42016-08-17 15:04:38 -05003
Patrick Williams864cc432023-02-09 14:54:44 -06004# Some BSPs use IMAGE_FSTYPES:<machine override> which would override
Andrew Geissler69721092021-07-23 12:57:00 -04005# an assignment to IMAGE_FSTYPES so we need anon python
6python () {
7 d.setVar("IMAGE_FSTYPES", d.getVar("INITRAMFS_FSTYPES"))
8}
Brad Bishop6e60e8b2018-02-01 10:27:11 -05009
Andrew Geissler69721092021-07-23 12:57:00 -040010inherit image
Patrick Williamsb48b7b42016-08-17 15:04:38 -050011
12# avoid circular dependencies
13EXTRA_IMAGEDEPENDS = ""
Brad Bishop6e60e8b2018-02-01 10:27:11 -050014KERNELDEPMODDEPEND = ""
Patrick Williamsb48b7b42016-08-17 15:04:38 -050015
16# We really need just kexecboot, kexec and ubiattach
17IMAGE_INSTALL = "kexecboot kexec mtd-utils-ubifs"
18
19# Do not pollute the initrd image with rootfs features
20IMAGE_FEATURES = ""
21
22IMAGE_LINGUAS = ""
23
24FEED_DEPLOYDIR_BASE_URI = ""
25LDCONFIGDEPEND = ""
Patrick Williamsb48b7b42016-08-17 15:04:38 -050026IMAGE_ROOTFS_EXTRA_SPACE = "0"
27
Brad Bishop6e60e8b2018-02-01 10:27:11 -050028# disable runtime dependency on run-postinsts -> update-rc.d
29ROOTFS_BOOTSTRAP_INSTALL = ""
30