blob: e70edef271ceec70e6fb8ed2db88a9aea8fa9766 [file] [log] [blame]
Patrick Williams864cc432023-02-09 14:54:44 -06001DESCRIPTION = "a graphical user interface that allows the user to change print settings"
2LICENSE = "GPL-2.0-only"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/OpenPrinting/system-config-printer.git;protocol=https;branch=master"
6
7SRCREV = "895d3dec50c93bfd4f142bac9bfcc13051bf84cb"
8S = "${WORKDIR}/git"
9
10inherit autotools gettext pkgconfig python3native features_check
11
12REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
13
14DEPENDS = "cups glib-2.0 libusb xmlto-native intltool-native desktop-file-utils-native"
15
16PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
17PACKAGECONFIG[systemd] = ",,systemd"
18
19do_configure:prepend() {
20 # This file is not provided if fetching from git but required for configure
21 touch ${S}/ChangeLog
22}
23
24FILES:${PN} += "${libdir} ${datadir}"
25
26RDEPENDS:${PN} = " \
27 dbus-x11 \
28 gtk+3 \
29 libnotify \
30 python3-core \
31 python3-dbus \
32 python3-firewall \
33 python3-pycups \
34 python3-pycurl \
35 python3-pygobject \
36"