blob: 2c68ba984fe33c8855f8dbfb246a200cb85bcf96 [file] [log] [blame]
Andrew Geissler97771a32021-03-05 15:23:11 -06001SUMMARY = "PKCS#11 HSM/Token Emulator"
2HOMEPAGE = "https://www.opendnssec.org/softhsm/"
3LICENSE = "BSD-2-Clause & ISC"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=ef3f77a3507c3d91e75b9f2bdaee4210"
5
6DEPENDS = "sqlite3"
7
Patrick Williams864cc432023-02-09 14:54:44 -06008SRC_URI = "https://dist.opendnssec.org/source/softhsm-2.6.1.tar.gz \
9 file://0001-avoid-unnecessary-check-for-sqlite3-binary.patch \
10"
Andrew Geissler97771a32021-03-05 15:23:11 -060011SRC_URI[sha256sum] = "61249473054bcd1811519ef9a989a880a7bdcc36d317c9c25457fc614df475f2"
12
13inherit autotools pkgconfig siteinfo
14
15EXTRA_OECONF += " --with-sqlite3=${STAGING_DIR_HOST}/usr"
Patrick Williams864cc432023-02-09 14:54:44 -060016EXTRA_OECONF += " --with-objectstore-backend-db"
Andrew Geissler97771a32021-03-05 15:23:11 -060017EXTRA_OECONF += "${@oe.utils.conditional('SITEINFO_BITS', '64', ' --enable-64bit', '', d)}"
18
19PACKAGECONFIG ?= "ecc eddsa pk11 openssl"
20
21PACKAGECONFIG[npm] = ",--disable-non-paged-memory"
22PACKAGECONFIG[ecc] = "--enable-ecc,--disable-ecc"
23PACKAGECONFIG[gost] = "--enable-gost,--disable-gost"
24PACKAGECONFIG[eddsa] = "--enable-eddsa, --disable-eddsa"
25PACKAGECONFIG[fips] = "--enable-fips, --disable-fips"
26PACKAGECONFIG[notvisable] = "--disable-visibility"
27PACKAGECONFIG[openssl] = "--with-openssl=${STAGING_DIR_HOST}/usr --with-crypto-backend=openssl, --without-openssl, openssl, openssl"
28PACKAGECONFIG[botan] = "--with-botan=${STAGING_DIR_HOST}/usr --with-crypto-backend=botan, --without-botan, botan"
29PACKAGECONFIG[migrate] = "--with-migrate"
30PACKAGECONFIG[pk11] = "--enable-p11-kit --with-p11-kit==${STAGING_DIR_HOST}/usr, --without-p11-kit, p11-kit, p11-kit"
31
Patrick Williams213cb262021-08-07 19:21:33 -050032RDEPENDS:${PN} = "sqlite3"
Andrew Geissler97771a32021-03-05 15:23:11 -060033BBCLASSEXTEND = "native nativesdk"