blob: d54f077cb09feef1aa5d48f7188425ec04d934ec [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001require glib.inc
2
3PE = "1"
4
5SHRT_VER = "${@oe.utils.trim_version("${PV}", 2)}"
6
7SRC_URI = "${GNOME_MIRROR}/glib/${SHRT_VER}/glib-${PV}.tar.xz \
8 file://run-ptest \
9 file://0001-Fix-DATADIRNAME-on-uclibc-Linux.patch \
10 file://0001-Remove-the-warning-about-deprecated-paths-in-schemas.patch \
11 file://0001-Install-gio-querymodules-as-libexec_PROGRAM.patch \
12 file://0010-Do-not-hardcode-python-path-into-various-tools.patch \
13 file://0001-Set-host_machine-correctly-when-building-with-mingw3.patch \
14 file://0001-Do-not-write-bindir-into-pkg-config-files.patch \
15 file://0001-meson-Run-atomics-test-on-clang-as-well.patch \
16 file://0001-gio-tests-resources.c-comment-out-a-build-host-only-.patch \
17 file://0001-gio-tests-g-file-info-don-t-assume-million-in-one-ev.patch \
18 file://0001-gio-tests-meson.build-do-not-use-can_run_host_binari.patch \
19 file://cpp-null.patch \
20 file://cpp-null2.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060021 "
22SRC_URI:append:class-native = " file://relocate-modules.patch"
23
Patrick Williams864cc432023-02-09 14:54:44 -060024SRC_URI[sha256sum] = "ceba83a5999ceb31a4c4fc9921207cb9ffffd2ab1d6ec03c162d3f608a5c14c8"
Andrew Geissler517393d2023-01-13 08:55:19 -060025
26# Find any meson cross files in FILESPATH that are relevant for the current
27# build (using siteinfo) and add them to EXTRA_OEMESON.
28inherit siteinfo
29def find_meson_cross_files(d):
30 if bb.data.inherits_class('native', d):
31 return ""
32
33 thisdir = os.path.normpath(d.getVar("THISDIR"))
34 import collections
35 sitedata = siteinfo_data(d)
36 # filename -> found
37 files = collections.OrderedDict()
38 for path in d.getVar("FILESPATH").split(":"):
39 for element in sitedata:
40 filename = os.path.normpath(os.path.join(path, "meson.cross.d", element))
41 sanitized_path = filename.replace(thisdir, "${THISDIR}")
42 if sanitized_path == filename:
43 if os.path.exists(filename):
44 bb.error("Cannot add '%s' to --cross-file, because it's not relative to THISDIR '%s' and sstate signature would contain this full path" % (filename, thisdir))
45 continue
46 files[filename.replace(thisdir, "${THISDIR}")] = os.path.exists(filename)
47
48 items = ["--cross-file=" + k for k,v in files.items() if v]
49 d.appendVar("EXTRA_OEMESON", " " + " ".join(items))
50 items = ["%s:%s" % (k, "True" if v else "False") for k,v in files.items()]
51 d.appendVarFlag("do_configure", "file-checksums", " " + " ".join(items))
52
53python () {
54 find_meson_cross_files(d)
55}