blob: 578dfb9d646a2b32e84761afbc3b6beb1ae2366e [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001HOMEPAGE = "http://mesonbuild.com"
2SUMMARY = "A high performance build system"
3DESCRIPTION = "Meson is a build system designed to increase programmer \
4productivity. It does this by providing a fast, simple and easy to use \
5interface for modern software development tools and practices."
6
7LICENSE = "Apache-2.0"
8LIC_FILES_CHKSUM = "file://COPYING;md5=3b83ef96387f14655fc854ddc3c6bd57"
9
10GITHUB_BASE_URI = "https://github.com/mesonbuild/meson/releases/"
11SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/meson-${PV}.tar.gz \
12 file://meson-setup.py \
13 file://meson-wrapper \
14 file://0001-python-module-do-not-manipulate-the-environment-when.patch \
15 file://disable-rpath-handling.patch \
16 file://0001-Make-CPU-family-warnings-fatal.patch \
17 file://0002-Support-building-allarch-recipes-again.patch \
18 file://0001-Check-for-clang-before-guessing-gcc-or-lcc.patch \
19 "
20SRC_URI[sha256sum] = "aa50a4ba4557c25e7d48446abfde857957dcdf58385fffbe670ba0e8efacce05"
21
22inherit python_setuptools_build_meta github-releases
23
24RDEPENDS:${PN} = "ninja python3-modules python3-pkg-resources"
25
26FILES:${PN} += "${datadir}/polkit-1"
27
28do_install:append () {
29 # As per the same issue in the python recipe itself:
30 # Unfortunately the following pyc files are non-deterministc due to 'frozenset'
31 # being written without strict ordering, even with PYTHONHASHSEED = 0
32 # Upstream is discussing ways to solve the issue properly, until then let's
33 # just not install the problematic files.
34 # More info: http://benno.id.au/blog/2013/01/15/python-determinism
35 rm ${D}${libdir}/python*/site-packages/mesonbuild/dependencies/__pycache__/mpi.cpython*
36}
37
38BBCLASSEXTEND = "native nativesdk"
39
40inherit meson-routines
41
42# The cross file logic is similar but not identical to that in meson.bbclass,
43# since it's generating for an SDK rather than a cross-compile. Important
44# differences are:
45# - We can't set vars like CC, CXX, etc. yet because they will be filled in with
46# real paths by meson-setup.sh when the SDK is extracted.
47# - Some overrides aren't needed, since the SDK injects paths that take care of
48# them.
49def var_list2str(var, d):
50 items = d.getVar(var).split()
51 return items[0] if len(items) == 1 else ', '.join(repr(s) for s in items)
52
53def generate_native_link_template(d):
54 val = ['-L@{OECORE_NATIVE_SYSROOT}${libdir_native}',
55 '-L@{OECORE_NATIVE_SYSROOT}${base_libdir_native}',
56 '-Wl,-rpath-link,@{OECORE_NATIVE_SYSROOT}${libdir_native}',
57 '-Wl,-rpath-link,@{OECORE_NATIVE_SYSROOT}${base_libdir_native}',
58 '-Wl,--allow-shlib-undefined'
59 ]
60 build_arch = d.getVar('BUILD_ARCH')
61 if 'x86_64' in build_arch:
62 loader = 'ld-linux-x86-64.so.2'
63 elif 'i686' in build_arch:
64 loader = 'ld-linux.so.2'
65 elif 'aarch64' in build_arch:
66 loader = 'ld-linux-aarch64.so.1'
67 elif 'ppc64le' in build_arch:
68 loader = 'ld64.so.2'
Patrick Williams864cc432023-02-09 14:54:44 -060069 elif 'loongarch64' in build_arch:
70 loader = 'ld-linux-loongarch-lp64d.so.1'
Andrew Geissler517393d2023-01-13 08:55:19 -060071
72 if loader:
73 val += ['-Wl,--dynamic-linker=@{OECORE_NATIVE_SYSROOT}${base_libdir_native}/' + loader]
74
75 return repr(val)
76
77install_templates() {
78 install -d ${D}${datadir}/meson
79
80 cat >${D}${datadir}/meson/meson.native.template <<EOF
81[binaries]
82c = ${@meson_array('BUILD_CC', d)}
83cpp = ${@meson_array('BUILD_CXX', d)}
84ar = ${@meson_array('BUILD_AR', d)}
85nm = ${@meson_array('BUILD_NM', d)}
86strip = ${@meson_array('BUILD_STRIP', d)}
87readelf = ${@meson_array('BUILD_READELF', d)}
88pkgconfig = 'pkg-config-native'
89
90[built-in options]
91c_args = ['-isystem@{OECORE_NATIVE_SYSROOT}${includedir_native}' , ${@var_list2str('BUILD_OPTIMIZATION', d)}]
92c_link_args = ${@generate_native_link_template(d)}
93cpp_args = ['-isystem@{OECORE_NATIVE_SYSROOT}${includedir_native}' , ${@var_list2str('BUILD_OPTIMIZATION', d)}]
94cpp_link_args = ${@generate_native_link_template(d)}
95[properties]
96sys_root = '@OECORE_NATIVE_SYSROOT'
97EOF
98
99 cat >${D}${datadir}/meson/meson.cross.template <<EOF
100[binaries]
101c = @CC
102cpp = @CXX
103ar = @AR
104nm = @NM
105strip = @STRIP
106pkgconfig = 'pkg-config'
107
108[built-in options]
109c_args = @CFLAGS
110c_link_args = @LDFLAGS
111cpp_args = @CPPFLAGS
112cpp_link_args = @LDFLAGS
113
114[properties]
115needs_exe_wrapper = true
116sys_root = @OECORE_TARGET_SYSROOT
117
118[host_machine]
119system = '$host_system'
120cpu_family = '$host_cpu_family'
121cpu = '$host_cpu'
122endian = '$host_endian'
123EOF
124}
125
126do_install:append:class-nativesdk() {
127 host_system=${SDK_OS}
128 host_cpu_family=${@meson_cpu_family("SDK_ARCH", d)}
129 host_cpu=${SDK_ARCH}
130 host_endian=${@meson_endian("SDK", d)}
131 install_templates
132
133 install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d
134 install -m 0755 ${WORKDIR}/meson-setup.py ${D}${SDKPATHNATIVE}/post-relocate-setup.d/
135
136 # We need to wrap the real meson with a thin env setup wrapper.
137 mv ${D}${bindir}/meson ${D}${bindir}/meson.real
138 install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson
139}
140
141FILES:${PN}:append:class-nativesdk = "${datadir}/meson ${SDKPATHNATIVE}"
142
143do_install:append:class-native() {
144 host_system=${HOST_OS}
145 host_cpu_family=${@meson_cpu_family("HOST_ARCH", d)}
146 host_cpu=${HOST_ARCH}
147 host_endian=${@meson_endian("HOST", d)}
148 install_templates
149
150 install -d ${D}${datadir}/post-relocate-setup.d
151 install -m 0755 ${WORKDIR}/meson-setup.py ${D}${datadir}/post-relocate-setup.d/
152
153 # We need to wrap the real meson with a thin wrapper that substitues native/cross files
154 # when running in a direct SDK environment.
155 mv ${D}${bindir}/meson ${D}${bindir}/meson.real
156 install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson
157}