blob: 822d21a58a7f06ce7e4d888a897f5104eb0fa237 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "Simple Python wrapper around the OpenSSL library"
2HOMEPAGE = "https://pyopenssl.org/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
5
6DEPENDS += "openssl ${PYTHON_PN}-cryptography"
7
Patrick Williams864cc432023-02-09 14:54:44 -06008SRC_URI[sha256sum] = "c1cc5f86bcacefc84dada7d31175cae1b1518d5f60d3d0bb595a67822a868a6f"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00009
10PYPI_PACKAGE = "pyOpenSSL"
11inherit pypi setuptools3
12
13PACKAGES =+ "${PN}-tests"
14FILES:${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
15
16RDEPENDS:${PN}:class-target = " \
17 ${PYTHON_PN}-cryptography \
18 ${PYTHON_PN}-six \
19 ${PYTHON_PN}-threading \
20"
21RDEPENDS:${PN}-tests = "${PN}"
22
23BBCLASSEXTEND = "native nativesdk"