blob: a412043a8b7405fd87e5dae84c6c70375a025db8 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Download, build, install, upgrade, and uninstall Python packages"
2HOMEPAGE = "https://pypi.org/project/setuptools"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=1;endline=19;md5=7a7126e068206290f3fe9f8d6c713ea6"
6
7inherit pypi python_setuptools_build_meta
8
9SRC_URI:append:class-native = " file://0001-conditionally-do-not-fetch-code-by-easy_install.patch"
10
Patrick Williams864cc432023-02-09 14:54:44 -060011SRC_URI += " \
Andrew Geissler517393d2023-01-13 08:55:19 -060012 file://0001-_distutils-sysconfig.py-make-it-possible-to-substite.patch"
13
Patrick Williams864cc432023-02-09 14:54:44 -060014SRC_URI[sha256sum] = "b440ee5f7e607bb8c9de15259dba2583dd41a38879a7abc1d43a71c59524da48"
Andrew Geissler517393d2023-01-13 08:55:19 -060015
16DEPENDS += "${PYTHON_PN}"
17
18RDEPENDS:${PN} = "\
19 ${PYTHON_PN}-2to3 \
20 ${PYTHON_PN}-compile \
21 ${PYTHON_PN}-compression \
22 ${PYTHON_PN}-ctypes \
23 ${PYTHON_PN}-email \
24 ${PYTHON_PN}-html \
25 ${PYTHON_PN}-json \
26 ${PYTHON_PN}-netserver \
27 ${PYTHON_PN}-numbers \
28 ${PYTHON_PN}-pickle \
29 ${PYTHON_PN}-pkg-resources \
30 ${PYTHON_PN}-pkgutil \
31 ${PYTHON_PN}-plistlib \
32 ${PYTHON_PN}-shell \
33 ${PYTHON_PN}-stringold \
34 ${PYTHON_PN}-threading \
35 ${PYTHON_PN}-unittest \
36 ${PYTHON_PN}-xml \
37"
38
39BBCLASSEXTEND = "native nativesdk"
40
41# The pkg-resources module can be used by itself, without the package downloader
42# and easy_install. Ship it in a separate package so that it can be used by
43# minimal distributions.
44PACKAGES =+ "${PYTHON_PN}-pkg-resources "
45FILES:${PYTHON_PN}-pkg-resources = "${PYTHON_SITEPACKAGES_DIR}/pkg_resources/*"
46RDEPENDS:${PYTHON_PN}-pkg-resources = "\
47 ${PYTHON_PN}-compression \
48 ${PYTHON_PN}-email \
49 ${PYTHON_PN}-plistlib \
50 ${PYTHON_PN}-pprint \
51"
52
53# This used to use the bootstrap install which didn't compile. Until we bump the
54# tmpdir version we can't compile the native otherwise the sysroot unpack fails
55INSTALL_WHEEL_COMPILE_BYTECODE:class-native = "--no-compile-bytecode"