blob: 13a8b49f709055d53278cfb80bf9d6ba5e8a67a3 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "System load testing utility"
2DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \
3imposes a configurable amount of CPU, memory, I/O, and disk stress on the system."
4HOMEPAGE = "https://github.com/ColinIanKing/stress-ng#readme"
5LICENSE = "GPL-2.0-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
7
8SRC_URI = "git://github.com/ColinIanKing/stress-ng.git;protocol=https;branch=master \
Andrew Geisslerc5535c92023-01-27 16:10:19 -06009 file://0001-test-float-Make-variables-global.patch \
Andrew Geissler517393d2023-01-13 08:55:19 -060010 file://0001-Pass-LD_GOLD-1-via-makefile-to-enable-gold-linker.patch"
Patrick Williams864cc432023-02-09 14:54:44 -060011SRCREV = "f3be0447c10fd5652b4c3753d56bcaac13fd8917"
Andrew Geissler517393d2023-01-13 08:55:19 -060012S = "${WORKDIR}/git"
13
14DEPENDS = "coreutils-native libbsd"
15
16PROVIDES = "stress"
17RPROVIDES:${PN} = "stress"
18RREPLACES:${PN} = "stress"
19RCONFLICTS:${PN} = "stress"
20
21inherit bash-completion
22
23EXTRA_OEMAKE = "VERBOSE=1"
24
25do_configure() {
26 mkdir -p configs
27 touch configs/HAVE_APPARMOR
28 oe_runmake makeconfig
29}
30
31do_install() {
32 oe_runmake DESTDIR=${D} BINDIR=${bindir} install
33 ln -s stress-ng ${D}${bindir}/stress
34}