blob: 6bcde521e2d2ad16611f2637163eded619a5515b [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "OpenGL / OpenGL ES Reference Compiler"
2DESCRIPTION = "Glslang is the official reference compiler front end for the \
3OpenGL ES and OpenGL shading languages. It implements a strict interpretation \
4of the specifications for these languages. It is open and free for anyone to use, \
5either from a command line or programmatically."
6SECTION = "graphics"
7HOMEPAGE = "https://www.khronos.org/opengles/sdk/tools/Reference-Compiler"
8LICENSE = "BSD-3-Clause & BSD-2-Clause & MIT & Apache-2.0 & GPL-3-with-bison-exception"
9LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=2a2b5acd7bc4844964cfda45fe807dc3"
10
Patrick Williams864cc432023-02-09 14:54:44 -060011SRCREV = "ca8d07d0bc1c6390b83915700439fa7719de6a2a"
12SRC_URI = "git://github.com/KhronosGroup/glslang.git;protocol=https;branch=main \
13 file://0001-generate-glslang-pkg-config.patch \
14 "
Andrew Geissler517393d2023-01-13 08:55:19 -060015PE = "1"
16UPSTREAM_CHECK_GITTAGREGEX = "sdk-(?P<pver>\d+(\.\d+)+)"
17S = "${WORKDIR}/git"
18
19inherit cmake python3native
20
21EXTRA_OECMAKE = " \
22 -DCMAKE_BUILD_TYPE=Release \
23 -DBUILD_SHARED_LIBS=ON \
24 -DENABLE_PCH=OFF \
25 -DENABLE_CTEST=OFF \
26 -DBUILD_EXTERNAL=OFF \
27"
28
29SOLIBSDEV = "glslang.so"
30# all the other libraries are unversioned, so pack it on PN
31FILES:${PN} += "${libdir}/*.so"
32
33BBCLASSEXTEND = "native nativesdk"