blob: f86885d3e3c3d7b78eb08d10929bb6efabfb1912 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "Library to handle input devices in Wayland compositors"
2DESCRIPTION = "libinput is a library to handle input devices in Wayland \
3compositors and to provide a generic X.Org input driver. It provides \
4device detection, device handling, input device event processing and \
5abstraction so minimize the amount of custom input code compositors need to \
6provide the common set of functionality that users expect."
7HOMEPAGE = "http://www.freedesktop.org/wiki/Software/libinput/"
8SECTION = "libs"
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://COPYING;md5=bab4ac7dc1c10bc0fb037dc76c46ef8a"
12
13DEPENDS = "libevdev udev mtdev libcheck"
14
Patrick Williams864cc432023-02-09 14:54:44 -060015SRC_URI = "git://gitlab.freedesktop.org/libinput/libinput.git;protocol=https;branch=1.22-branch \
Andrew Geissler517393d2023-01-13 08:55:19 -060016 file://run-ptest \
17 file://determinism.patch \
18 "
Patrick Williams864cc432023-02-09 14:54:44 -060019SRCREV = "d9f45fd1261da85b4eb44f8aa82e1500b99f303b"
Andrew Geissler517393d2023-01-13 08:55:19 -060020S = "${WORKDIR}/git"
21
22UPSTREAM_CHECK_REGEX = "libinput-(?P<pver>\d+\.\d+\.(?!9\d+)\d+)"
23
24inherit meson pkgconfig lib_package ptest
25
26# Patch out build directory, otherwise it leaks into ptest binary
27do_configure:append() {
28 sed -i -e "s,${WORKDIR},,g" config.h
29 if [ -e "litest-config.h" ]; then
30 sed -i -e "s,${WORKDIR},,g" litest-config.h
31 fi
32}
33
34PACKAGECONFIG ??= ""
35PACKAGECONFIG[libwacom] = "-Dlibwacom=true,-Dlibwacom=false,libwacom"
36PACKAGECONFIG[gui] = "-Ddebug-gui=true,-Ddebug-gui=false,cairo gtk+3"
37
38UDEVDIR = "`pkg-config --variable=udevdir udev`"
39
40EXTRA_OEMESON += "-Dudev-dir=${UDEVDIR} \
41 -Ddocumentation=false \
42 ${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true -Dinstall-tests=true', '-Dtests=false -Dinstall-tests=false', d)} \
43 -Dzshcompletiondir=no"
44
45# package name changed in 1.8.1 upgrade: make sure package upgrades work
46RPROVIDES:${PN} = "libinput"
47RREPLACES:${PN} = "libinput"
48RCONFLICTS:${PN} = "libinput"
49
50FILES:${PN}-ptest += "${libexecdir}/libinput/libinput-test-suite"