blob: 8ddb851f71a11cb1edf048118e621a1617bb7c46 [file] [log] [blame]
Andrew Geissler517393d2023-01-13 08:55:19 -06001SUMMARY = "HTTP/2 C Library and tools"
2HOMEPAGE = "https://nghttp2.org/"
3SECTION = "libs"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=764abdf30b2eadd37ce47dcbce0ea1ec"
6
7SRC_URI = "\
8 ${GITHUB_BASE_URI}/download/v${PV}/nghttp2-${PV}.tar.xz \
9 file://0001-fetch-ocsp-response-use-python3.patch \
10"
11SRC_URI[sha256sum] = "66aa76d97c143f42295405a31413e5e7d157968dad9f957bb4b015b598882e6b"
12
13inherit cmake manpages python3native github-releases
14PACKAGECONFIG[manpages] = ""
15
16# examples are never installed, and don't need to be built in the
17# first place
Patrick Williams864cc432023-02-09 14:54:44 -060018EXTRA_OECMAKE = "-DENABLE_EXAMPLES=OFF -DENABLE_APP=OFF -DENABLE_HPACK_TOOLS=OFF -DENABLE_PYTHON_BINDINGS=OFF"
Andrew Geissler517393d2023-01-13 08:55:19 -060019
20PACKAGES =+ "lib${BPN} ${PN}-client ${PN}-proxy ${PN}-server"
21
22RDEPENDS:${PN} = "${PN}-client (>= ${PV}) ${PN}-proxy (>= ${PV}) ${PN}-server (>= ${PV})"
23RDEPENDS:${PN}:class-native = ""
24RDEPENDS:${PN}-proxy = "openssl python3-core python3-io python3-shell"
25
26ALLOW_EMPTY:${PN} = "1"
27FILES:${PN} = ""
28FILES:lib${BPN} = "${libdir}/*${SOLIBS}"
29FILES:${PN}-client = "${bindir}/h2load ${bindir}/nghttp"
30FILES:${PN}-proxy = "${bindir}/nghttpx ${datadir}/${BPN}/fetch-ocsp-response"
31FILES:${PN}-server = "${bindir}/nghttpd"
32
33BBCLASSEXTEND = "native nativesdk"