blob: aeadc9d5ddc0ff06ac215df26434775ef7ebc89d [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Kernel based automounter for linux"
2SECTION = "utils"
3LICENSE = "GPL-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
5
6DEPENDS += "libtirpc flex-native bison-native e2fsprogs openssl libxml2 util-linux cyrus-sasl libnsl2"
7
8CFLAGS += "-I${STAGING_INCDIR}/tirpc"
9
10inherit autotools-brokensep systemd update-rc.d pkgconfig
11
12SRC_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/autofs-${PV}.tar.gz \
13 file://autofs-5.0.7-include-linux-nfs.h-directly-in-rpc_sub.patch \
14 file://no-bash.patch \
15 file://cross.patch \
16 file://fix_disable_ldap.patch \
17 file://autofs-5.0.7-fix-lib-deps.patch \
18 file://add-the-needed-stdarg.h.patch \
19 file://using-pkg-config-to-detect-libxml-2.0-and-krb5.patch \
20 file://force-STRIP-to-emtpy.patch \
21 file://remove-bashism.patch \
22 file://fix-the-YACC-rule-to-fix-a-building-failure.patch \
23 file://0001-Define-__SWORD_TYPE-and-_PATH_NSSWITCH_CONF.patch \
24 file://0002-Replace-__S_IEXEC-with-S_IEXEC.patch \
25 file://pkgconfig-libnsl.patch \
26 file://0001-modules-lookup_multi.c-Replace-__S_IEXEC-with-S_IEXE.patch \
27 file://0001-Do-not-hardcode-path-for-pkg.m4.patch \
Brad Bishop868407c2019-11-04 13:24:47 -050028 file://0001-Bug-fix-for-pid_t-not-found-on-musl.patch \
Brad Bishop19323692019-04-05 15:28:33 -040029 "
30
31
Brad Bishop868407c2019-11-04 13:24:47 -050032SRC_URI[md5sum] = "e6800e0afd6009ecdff148088c564050"
33SRC_URI[sha256sum] = "82094cad44f4e5c4f93eff2789cd66b57d7ab3fa646b7722d97608571001e694"
Brad Bishop19323692019-04-05 15:28:33 -040034
35UPSTREAM_CHECK_URI = "${KERNELORG_MIRROR}/linux/daemons/autofs/v5/"
36
37INITSCRIPT_NAME = "autofs"
38INITSCRIPT_PARAMS = "defaults"
39
40# FIXME: modules/Makefile has crappy rules that don't obey LDFLAGS
41#CFLAGS += "${LDFLAGS}"
42
43PACKAGECONFIG[systemd] = "--with-systemd=${systemd_unitdir}/system,--without-systemd,systemd"
44
45PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
46
47EXTRA_OEMAKE = "DONTSTRIP=1"
48EXTRA_OECONF += "--disable-mount-locking \
49 --enable-ignore-busy --with-openldap=no \
50 --with-sasl=no --with-libtirpc \
51 --with-path=${STAGING_BINDIR_NATIVE} \
52 --with-fifodir=${localstatedir}/run \
53 --with-flagdir=${localstatedir}/run \
54"
55CACHED_CONFIGUREVARS = "ac_cv_path_RANLIB=${RANLIB} \
56 ac_cv_path_RPCGEN=rpcgen \
57"
58
59do_configure_prepend () {
60 if [ ! -e ${S}/acinclude.m4 ]; then
61 cp ${S}/aclocal.m4 ${S}/acinclude.m4
62 fi
63 cp ${STAGING_DATADIR_NATIVE}/aclocal/pkg.m4 .
64}
65
66do_install_append () {
67 # samples have been removed from SUBDIRS from 5.1.5, need to install separately
68 oe_runmake 'DESTDIR=${D}' install_samples
69
70 if [ -d ${D}/run ]; then
71 rmdir ${D}/run
72 fi
73 if [ -d ${D}${localstatedir}/run ]; then
74 rmdir ${D}${localstatedir}/run
75 fi
76}
77SECURITY_CFLAGS = "${SECURITY_NO_PIE_CFLAGS}"
78
79INSANE_SKIP_${PN} = "dev-so"
80
81RPROVIDES_${PN} += "${PN}-systemd"
82RREPLACES_${PN} += "${PN}-systemd"
83RCONFLICTS_${PN} += "${PN}-systemd"
84SYSTEMD_SERVICE_${PN} = "autofs.service"
85