blob: 8fdaf848ff2734b344f5ea62d0f80413dce61665 [file] [log] [blame]
Brad Bishopd7bf8c12018-02-25 22:55:05 -05001SUMMARY = "A 802.1ab implementation (LLDP) to help you locate neighbors of all your equipments"
2SECTION = "net/misc"
3LICENSE = "ISC"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/ISC;md5=f3b90e78ea0cffb20bf5cca7947a896d"
5
6DEPENDS = "libbsd libevent"
7
8SRC_URI = "\
9 http://media.luffy.cx/files/${BPN}/${BPN}-${PV}.tar.gz \
10 file://lldpd.init.d \
11 file://lldpd.default \
Brad Bishopd7bf8c12018-02-25 22:55:05 -050012 "
13
Brad Bishop868407c2019-11-04 13:24:47 -050014SRC_URI[md5sum] = "33e8d58623f99184e4e709cbbfe45db3"
15SRC_URI[sha256sum] = "5319bc032fabf1008d5d91e280276aa7f1bbfbb70129d8526cd4526d7c22724f"
Brad Bishopd7bf8c12018-02-25 22:55:05 -050016
17inherit autotools update-rc.d useradd systemd pkgconfig bash-completion
18
19USERADD_PACKAGES = "${PN}"
20USERADD_PARAM_${PN} = "--system -g lldpd --shell /bin/false lldpd"
21GROUPADD_PARAM_${PN} = "--system lldpd"
22
23EXTRA_OECONF += "--without-embedded-libevent \
24 --disable-oldies \
25 --with-privsep-user=lldpd \
26 --with-privsep-group=lldpd \
27 --with-systemdsystemunitdir=${systemd_system_unitdir} \
28 --without-sysusersdir \
29"
30
31PACKAGECONFIG ??= "cdp fdp edp sonmp lldpmed dot1 dot3"
32PACKAGECONFIG[xml] = "--with-xml,--without-xml,libxm2"
33PACKAGECONFIG[snmp] = "--with-snmp,--without-snmp,net-snmp"
34PACKAGECONFIG[readline] = "--with-readline,--without-readline,readline"
35PACKAGECONFIG[seccomp] = "--with-seccomp,--without-seccomp,libseccomp"
36PACKAGECONFIG[cdp] = "--enable-cdp,--disable-cdp"
37PACKAGECONFIG[fdp] = "--enable-fdp,--disable-fdp"
38PACKAGECONFIG[edp] = "--enable-edp,--disable-edp"
39PACKAGECONFIG[sonmp] = "--enable-sonmp,--disable-sonmp"
40PACKAGECONFIG[lldpmed] = "--enable-lldpmed,--disable-lldpmed"
41PACKAGECONFIG[dot1] = "--enable-dot1,--disable-dot1"
42PACKAGECONFIG[dot3] = "--enable-dot3,--disable-dot3"
43PACKAGECONFIG[custom] = "--enable-custom,--disable-custom"
44
45INITSCRIPT_NAME = "lldpd"
46INITSCRIPT_PARAMS = "defaults"
47
48SYSTEMD_SERVICE_${PN} = "lldpd.service"
49
50do_install_append() {
51 install -Dm 0755 ${WORKDIR}/lldpd.init.d ${D}${sysconfdir}/init.d/lldpd
52 install -Dm 0644 ${WORKDIR}/lldpd.default ${D}${sysconfdir}/default/lldpd
53 # Make an empty configuration file
54 touch ${D}${sysconfdir}/lldpd.conf
55}
56
57PACKAGES =+ "${PN}-zsh-completion"
58
59FILES_${PN} += "${libdir}/sysusers.d"
60RDEPENDS_${PN} += "os-release"
61
62FILES_${PN}-zsh-completion += "${datadir}/zsh/"
63# FIXME: zsh is broken in meta-oe so this cannot be enabled for now
64#RDEPENDS_${PN}-zsh-completion += "zsh"