blob: 89050e4f7e8c5f6ad5af7ef5d3553e2310125885 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "Phoronix Test Suite"
2DESCRIPTION = "The Phoronix Test Suite is designed to carry out both qualitative \
3and quantitative benchmarks in a clean, reproducible, and easy-to-use manner."
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6SECTION = "console/tests"
7
8SRC_URI = "http://www.phoronix-test-suite.com/releases/${BP}.tar.gz"
Brad Bishop868407c2019-11-04 13:24:47 -05009SRC_URI[md5sum] = "58023c8136a0206909552942660fe28a"
10SRC_URI[sha256sum] = "a117a4350774e67989d90bf0b5e82a8072652f8caa60a62c3e5f64adc317ce14"
Brad Bishop19323692019-04-05 15:28:33 -040011
12S = "${WORKDIR}/phoronix-test-suite"
13
14inherit systemd allarch
15
16do_install() {
17 DESTDIR=${D} ./install-sh ${exec_prefix}
18
19 if [ "${systemd_unitdir}" != "/usr/lib/systemd" ]; then
20 install -d ${D}/${systemd_unitdir}/system/
21 mv ${D}/usr/lib/systemd/system/* ${D}/${systemd_unitdir}/system/
22 rm -rf ${D}/usr/lib/
23 fi
24}
25
26# It is not advisable to enable these services by default since they can cause
27# continual target reboots if they encounter network problems.
28#
29SYSTEMD_AUTO_ENABLE = "disable"
30SYSTEMD_SERVICE_${PN} = "phoromatic-client.service phoromatic-server.service"
31
Brad Bishop0f291cc2019-09-01 15:16:57 -040032RDEPENDS_${PN} += "bash python php-cli util-linux-lscpu os-release lsb-release"
Brad Bishop19323692019-04-05 15:28:33 -040033
34FILES_${PN} += " \
35 ${datadir}/phoronix-test-suite \
36 ${datadir}/appdata/phoronix-test-suite.appdata.xml \
37 ${datadir}/icons/hicolor/48x48/apps/phoronix-test-suite.png \
38 ${datadir}/icons/hicolor/64x64/mimetypes/application-x-openbenchmarking.png \
39 ${datadir}/mime/packages/openbenchmarking-mime.xml \
40 ${systemd_unitdir}/* \
41"