blob: 074a1a5f69e2704f3af99f6acb92cc94222c1f1f [file] [log] [blame]
Brad Bishop868407c2019-11-04 13:24:47 -05001DESCRIPTION = "flashrom is a utility for identifying, reading, writing, verifying and erasing flash chips"
2LICENSE = "GPLv2"
3HOMEPAGE = "http://flashrom.org"
4
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6DEPENDS = "pciutils libusb libusb-compat"
7
8SRC_URI = "https://download.flashrom.org/releases/flashrom-v${PV}.tar.bz2 \
9 "
10SRC_URI[md5sum] = "91bab6c072e38a493bb4eb673e4fe0d6"
11SRC_URI[sha256sum] = "aeada9c70c22421217c669356180c0deddd0b60876e63d2224e3260b90c14e19"
12
13S = "${WORKDIR}/flashrom-v${PV}"
14
15inherit pkgconfig
16
17do_install() {
18 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
19}