blob: 89ab565ce588bf8118dcb237d99d605fd21ec098 [file] [log] [blame]
Brad Bishop868407c2019-11-04 13:24:47 -05001SUMMARY = "Unicode Character Database"
2HOMEPAGE = "https://unicode.org/ucd/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://unicode.org.license.html;beginline=42;endline=85;md5=67619d0c52706853c0256514e7fd04cd"
5
6SRC_URI = " \
7 https://www.unicode.org/Public/zipped/${PV}/UCD.zip;name=ucd;subdir=ucd \
8 https://www.unicode.org/license.html;name=license;subdir=${BP};downloadfilename=unicode.org.license.html \
9"
10SRC_URI[ucd.md5sum] = "430cbdac2615451571dd69a976dd08f6"
11SRC_URI[ucd.sha256sum] = "25ba51a0d4c6fa41047b7a5e5733068d4a734588f055f61e85f450097834a0a6"
12
13SRC_URI[license.md5sum] = "f03bafb623258f85ff2032c1ce567b7c"
14SRC_URI[license.sha256sum] = "983225207de8a707d0903a8d70fb7a4b28c5e0f64f2366e84a6192a2d618fed4"
15
16inherit allarch
17
18do_configure[noexec] = "1"
19
20do_install() {
21 install -d ${D}${datadir}/unicode
22 cp -rf ${WORKDIR}/ucd ${D}${datadir}/unicode
23}
24
25FILES_${PN} = "${datadir}/unicode/ucd"