blob: b3942fc30e8f70b8e32dd1b66ad4c39f609ead1f [file] [log] [blame]
Brad Bishopc342db32019-05-15 21:57:59 -04001SUMMARY = "Embedded Linux Library"
2DESCRIPTION = "The Embedded Linux Library (ELL) provides core, \
3low-level functionality for system daemons. It typically has no \
4dependencies other than the Linux kernel, C standard library, and \
5libdl (for dynamic linking). While ELL is designed to be efficient \
6and compact enough for use on embedded Linux platforms, it is not \
7limited to resource-constrained systems."
8SECTION = "libs"
9LICENSE = "LGPLv2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=fb504b67c50331fc78734fed90fb0e09"
11
12DEPENDS = "dbus"
13
14inherit autotools pkgconfig
15
16SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz"
Brad Bishop79641f22019-09-10 07:20:22 -040017SRC_URI[md5sum] = "a4e7d74404f11e71775b89f53a8f1c33"
18SRC_URI[sha256sum] = "3c1d6d997e17dfcbe4ebcd1331d9a7be5c64f2f0a0813bc223790e570d8da2e3"
Brad Bishopc342db32019-05-15 21:57:59 -040019
20do_configure_prepend () {
21 mkdir -p ${S}/build-aux
22}