blob: 2299199c31f274c8054205f53ebbea61f411a8b4 [file] [log] [blame]
Brad Bishop19323692019-04-05 15:28:33 -04001SUMMARY = "A library for bits of crypto UI and parsing etc"
2HOMEPAGE = "http://www.gnome.org/"
3BUGTRACKER = "https://bugzilla.gnome.org/"
4
5LICENSE = "GPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=55ca817ccb7d5b5b66355690e9abc605"
7
8DEPENDS = "intltool-native gtk+3 p11-kit glib-2.0 libgcrypt \
9 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', 'libxslt-native', '', d)}"
10
11inherit gnomebase gtk-icon-cache gtk-doc distro_features_check upstream-version-is-even vala gobject-introspection
12# depends on gtk+3, but also x11 through gtk+-x11
13REQUIRED_DISTRO_FEATURES = "x11"
14
15SRC_URI[archive.md5sum] = "afd88cacfd54c1ac5b3e0eb35e3aa674"
16SRC_URI[archive.sha256sum] = "95204aa2111c301778ebfbe60975ce3ed698c958430ffcc2a785ac5e593d168b"
17
18FILES_${PN} += " \
19 ${datadir}/dbus-1 \
20 ${datadir}/gcr-3 \
21"
22
23# http://errors.yoctoproject.org/Errors/Details/20229/
24ARM_INSTRUCTION_SET_armv4 = "arm"
25ARM_INSTRUCTION_SET_armv5 = "arm"
26ARM_INSTRUCTION_SET_armv6 = "arm"
27
28# These files may be out of date or missing our fixes
29# libgcrypt.m4 in particular is calling into libgcrypt-config
30do_configure_prepend() {
31 rm -f ${S}/build/m4/*
32}