blob: fed29da0fc442261101009121a9c96f32339301a [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001SUMMARY = "A GObject-based Exiv2 wrapper"
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Andrew Geissler595f6302022-01-24 19:11:47 +00003LIC_FILES_CHKSUM = "file://COPYING;md5=625f055f41728f84a8d7938acc35bdc2"
4
5DEPENDS = "exiv2 python3-pygobject-native"
6
7GNOMEBASEBUILDCLASS = "meson"
8GTKDOC_MESON_OPTION = "gtk_doc"
9
10inherit gnomebase gobject-introspection gtk-doc python3native
11
12SRC_URI[archive.sha256sum] = "e58279a6ff20b6f64fa499615da5e9b57cf65ba7850b72fafdf17221a9d6d69e"
13
14EXTRA_OEMESON = " \
15 -Dvapi=false \
16 -Dpython3_girdir=${PYTHON_SITEPACKAGES_DIR}/gi/overrides \
17"
18
19PACKAGES =+ "${PN}-python3"
20FILES:${PN}-python3 = "${PYTHON_SITEPACKAGES_DIR}"
21RDEPENDS:${PN}-python3 = "${PN}"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050022
23PACKAGE_PREPROCESS_FUNCS += "src_package_preprocess"
24src_package_preprocess () {
25 # Trim build paths from comments in generated sources to ensure reproducibility
26 sed -i -e "s,${B}/../${BPN}-${PV}/${BPN}/,,g" \
27 ${B}/gexiv2/gexiv2-enums.cpp
28}