blob: ed0fbb6f016efbe8bc2173d282a980ee56597de8 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001SUMMARY = "Tracker is a file search engine"
2LICENSE = "GPL-2.0-only & LGPL-2.1-only"
3LIC_FILES_CHKSUM = " \
4 file://COPYING.GPL;md5=ee31012bf90e7b8c108c69f197f3e3a4 \
5 file://COPYING.LGPL;md5=2d5025d4aa3495befef8f17206a5b0a1 \
6"
7
8DEPENDS = " \
9 dbus-native \
10 python3-pygobject-native \
11 glib-2.0 \
12 sqlite3 \
13 libarchive \
14 dbus \
15 icu \
16 json-glib \
17 libsoup-2.4 \
18 libstemmer \
19"
20
21GNOMEBASEBUILDCLASS = "meson"
22
23inherit gnomebase gsettings gobject-introspection vala gtk-doc manpages bash-completion features_check python3native
24
Andrew Geissler87f5cff2022-09-30 13:13:31 -050025SRC_URI[archive.sha256sum] = "b3b380c9571d7c7423b5f401e4a2f2d78de47143b035eb2c1281e2423c59218b"
Patrick Williams92b42cb2022-09-03 06:53:57 -050026
27# gobject-introspection is mandatory and cannot be configured
28REQUIRED_DISTRO_FEATURES = "gobject-introspection-data"
29GIR_MESON_OPTION = ""
30
31# text search is not an option anymore and requires sqlite3 build with
32# PACKAGECONFIG[fts5] set (default)
33
34# set required cross property sqlite3_has_fts5
35do_write_config[vardeps] += "PACKAGECONFIG"
36do_write_config:append() {
37 echo "[properties]" > ${WORKDIR}/meson-tracker.cross
38 echo "sqlite3_has_fts5 = 'true'" >> ${WORKDIR}/meson-tracker.cross
39}
40
41EXTRA_OEMESON = " \
42 --cross-file ${WORKDIR}/meson-tracker.cross \
43 -Dman=false \
44 -Dsystemd_user_services=${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)} \
45 -Dsystemd_user_services_dir=${systemd_user_unitdir} \
46"
47
48FILES:${PN} += " \
49 ${datadir}/dbus-1 \
50 ${datadir}/tracker3 \
51 ${libdir}/tracker-3.0 \
52 ${systemd_user_unitdir} \
53"