blob: 3aa4f407af0fb7bdcbe50ad0285d08094da0d551 [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "wolfSSL Lightweight Embedded SSL/TLS Library"
2DESCRIPTION = "wolfSSL, formerly CyaSSL, is a lightweight SSL library written \
3 in C and optimized for embedded and RTOS environments. It can \
4 be up to 20 times smaller than OpenSSL while still supporting \
5 a full TLS client and server, up to TLS 1.3"
6HOMEPAGE = "https://www.wolfssl.com/products/wolfssl"
7BUGTRACKER = "https://github.com/wolfssl/wolfssl/issues"
8SECTION = "libs"
Andrew Geissler9aee5002022-03-30 16:27:02 +00009LICENSE = "GPL-2.0-only"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000010LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12PROVIDES += "cyassl"
13RPROVIDES:${PN} = "cyassl"
14
15SRC_URI = "git://github.com/wolfSSL/wolfssl.git;protocol=https;branch=master"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050016SRCREV = "44f81f8bc082319cebf0e37df8470aa5748c1355"
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000017
18S = "${WORKDIR}/git"
19
20inherit autotools
21
22BBCLASSEXTEND += "native nativesdk"