blob: 0682eafa09571e0271e614c80bce747a8bb04b8c [file] [log] [blame]
Andrew Geissler7e0e3c02022-02-25 20:34:39 +00001SUMMARY = "sends ICMP ECHO_REQUEST packets to network hosts"
2DESCRIPTION = "fping is a ping like program which uses the Internet Control \
3Message Protocol (ICMP) echo request to determine if a target host is \
4responding. fping differs from ping in that you can specify any number of \
5targets on the command line, or specify a file containing the lists of \
6targets to ping. Instead of sending to one target until it times out or \
7replies, fping will send out a ping packet and move on to the next target \
8in a round-robin fashion."
9HOMEPAGE = "http://www.fping.org/"
10BUGTRACKER = "https://github.com/schweikert/fping/issues"
11SECTION = "net"
12
13LICENSE = "fping"
14NO_GENERIC_LICENSE[fping] = "COPYING"
15LIC_FILES_CHKSUM = "file://COPYING;md5=c6170fbadddfcd74f011515291d96901"
16
Andrew Geissler87f5cff2022-09-30 13:13:31 -050017SRC_URI = "http://www.fping.org/dist/fping-${PV}.tar.gz \
18 file://0001-fping-Initialize-msghdr-struct-in-a-portable-way.patch \
19 "
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000020SRC_URI[sha256sum] = "1ee5268c063d76646af2b4426052e7d81a42b657e6a77d8e7d3d2e60fd7409fe"
21
22S = "${WORKDIR}/fping-${PV}"
23
24inherit autotools
25
26EXTRA_OECONF = "--enable-ipv4"
27
28PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
29PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"