blob: 72f37aea850e1e23744eb009836606a84e6fab0f [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "A simple daemon to allow session software to update firmware"
2LICENSE = "LGPL-2.1-or-later"
3LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
4
Andrew Geissler87f5cff2022-09-30 13:13:31 -05005DEPENDS = "glib-2.0 libxmlb json-glib libjcat gcab vala-native"
Andrew Geissler9aee5002022-03-30 16:27:02 +00006
Andrew Geissler9aee5002022-03-30 16:27:02 +00007SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/${PV}/${BP}.tar.xz \
Andrew Geissler87f5cff2022-09-30 13:13:31 -05008 file://c54ae9c524998e449b822feb465a0c90317cd735.patch \
Andrew Geissler9aee5002022-03-30 16:27:02 +00009 file://run-ptest"
Andrew Geissler87f5cff2022-09-30 13:13:31 -050010SRC_URI[sha256sum] = "adfa07434cdc29ec41c40fef460e8d970963fe0c7e849dec7f3932adb161f886"
Andrew Geissler9aee5002022-03-30 16:27:02 +000011
12UPSTREAM_CHECK_URI = "https://github.com/${BPN}/${BPN}/releases"
13
14# Machine-specific as we examine MACHINE_FEATURES to decide whether to build the UEFI plugins
15PACKAGE_ARCH = "${MACHINE_ARCH}"
16
17inherit meson vala gobject-introspection systemd bash-completion pkgconfig gi-docgen ptest manpages
18
19GIDOCGEN_MESON_OPTION = 'docs'
20GIDOCGEN_MESON_ENABLE_FLAG = 'docgen'
21GIDOCGEN_MESON_DISABLE_FLAG = 'none'
22
23PACKAGECONFIG ??= "curl gnutls gudev gusb \
24 ${@bb.utils.filter('DISTRO_FEATURES', 'bluetooth polkit', d)} \
25 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd offline', '', d)} \
26 ${@bb.utils.contains('MACHINE_FEATURES', 'efi', 'plugin_uefi_capsule plugin_uefi_pk', '', d)} \
27 ${@bb.utils.contains('PTEST_ENABLED', '1', 'tests plugin_dummy', '', d)} \
28 hsi \
29 plugin_acpi_phat \
30 plugin_amt \
31 plugin_bcm57xx \
32 plugin_emmc \
33 plugin_ep963x \
34 plugin_fastboot \
35 plugin_flashrom \
36 plugin_gpio \
37 plugin_intel_spi \
38 plugin_logitech_bulkcontroller \
39 plugin_modem_manager \
40 plugin_msr \
41 plugin_nitrokey \
42 plugin_nvme \
43 plugin_parade_lspcon \
44 plugin_pixart_rf \
45 plugin_platform_integrity \
46 plugin_realtek_mst \
47 plugin_redfish \
48 plugin_synaptics_mst \
49 plugin_synaptics_rmi \
50 plugin_scsi \
Andrew Geissler9aee5002022-03-30 16:27:02 +000051 plugin_uf2 \
52 plugin_upower \
53 sqlite"
54
55PACKAGECONFIG[bluetooth] = "-Dbluez=true,-Dbluez=false"
56PACKAGECONFIG[compat-cli] = "-Dcompat_cli=true,-Dcompat_cli=false"
57PACKAGECONFIG[consolekit] = "-Dconsolekit=true,-Dconsolekit=false,consolekit"
58PACKAGECONFIG[curl] = "-Dcurl=true,-Dcurl=false,curl"
59PACKAGECONFIG[firmware-packager] = "-Dfirmware-packager=true,-Dfirmware-packager=false"
60PACKAGECONFIG[fish-completion] = "-Dfish_completion=true,-Dfish_completion=false"
61PACKAGECONFIG[gnutls] = "-Dgnutls=true,-Dgnutls=false,gnutls"
62PACKAGECONFIG[gudev] = "-Dgudev=true,-Dgudev=false,libgudev"
63PACKAGECONFIG[gusb] = "-Dgusb=true,-Dgusb=false,libgusb"
64PACKAGECONFIG[hsi] = "-Dhsi=true,-Dhsi=false"
65PACKAGECONFIG[libarchive] = "-Dlibarchive=true,-Dlibarchive=false,libarchive"
66PACKAGECONFIG[manpages] = "-Dman=true,-Dman=false"
67PACKAGECONFIG[metainfo] = "-Dmetainfo=true,-Dmetainfo=false"
68PACKAGECONFIG[offline] = "-Doffline=true,-Doffline=false"
69PACKAGECONFIG[polkit] = "-Dpolkit=true,-Dpolkit=false,polkit"
70PACKAGECONFIG[sqlite] = "-Dsqlite=true,-Dsqlite=false,sqlite3"
71PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd"
72PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,gcab-native"
73
74
75# TODO plugins-all meta-option that expands to all plugin_*?
76PACKAGECONFIG[plugin_acpi_phat] = "-Dplugin_acpi_phat=true,-Dplugin_acpi_phat=false"
77PACKAGECONFIG[plugin_amt] = "-Dplugin_amt=true,-Dplugin_amt=false"
78PACKAGECONFIG[plugin_bcm57xx] = "-Dplugin_bcm57xx=true,-Dplugin_bcm57xx=false"
79PACKAGECONFIG[plugin_cfu] = "-Dplugin_cfu=true,-Dplugin_cfu=false"
80PACKAGECONFIG[plugin_dell] = "-Dplugin_dell=true,-Dplugin_dell=false,libsmbios"
81PACKAGECONFIG[plugin_dummy] = "-Dplugin_dummy=true,-Dplugin_dummy=false"
82PACKAGECONFIG[plugin_emmc] = "-Dplugin_emmc=true,-Dplugin_emmc=false"
83PACKAGECONFIG[plugin_ep963x] = "-Dplugin_ep963x=true,-Dplugin_ep963x=false"
84PACKAGECONFIG[plugin_fastboot] = "-Dplugin_fastboot=true,-Dplugin_fastboot=false"
85PACKAGECONFIG[plugin_flashrom] = "-Dplugin_flashrom=true,-Dplugin_flashrom=false,flashrom"
86PACKAGECONFIG[plugin_gpio] = "-Dplugin_gpio=true,-Dplugin_gpio"
87PACKAGECONFIG[plugin_intel_spi] = "-Dplugin_intel_spi=true -Dlzma=true,-Dplugin_intel_spi=false -Dlzma=false,xz"
88PACKAGECONFIG[plugin_logitech_bulkcontroller] = "-Dplugin_logitech_bulkcontroller=true,-Dplugin_logitech_bulkcontroller=false,protobuf-c-native protobuf-c"
89PACKAGECONFIG[plugin_modem_manager] = "-Dplugin_modem_manager=true,-Dplugin_modem_manager=false,libqmi modemmanager"
90PACKAGECONFIG[plugin_msr] = "-Dplugin_msr=true,-Dplugin_msr=false,cpuid"
91PACKAGECONFIG[plugin_nitrokey] = "-Dplugin_nitrokey=true,-Dplugin_nitrokey=false"
92PACKAGECONFIG[plugin_nvme] = "-Dplugin_nvme=true,-Dplugin_nvme=false"
93PACKAGECONFIG[plugin_parade_lspcon] = "-Dplugin_parade_lspcon=true,-Dplugin_parade_lspcon=false"
94PACKAGECONFIG[plugin_pixart_rf] = "-Dplugin_pixart_rf=true,-Dplugin_pixart_rf=false"
95PACKAGECONFIG[plugin_platform_integrity] = "-Dplugin_platform_integrity=true,-Dplugin_platform_integrity=false"
96PACKAGECONFIG[plugin_powerd] = "-Dplugin_powerd=true,-Dplugin_powerd=false"
97PACKAGECONFIG[plugin_realtek_mst] = "-Dplugin_realtek_mst=true,-Dplugin_realtek_mst=false"
98PACKAGECONFIG[plugin_redfish] = "-Dplugin_redfish=true,-Dplugin_redfish=false"
99PACKAGECONFIG[plugin_scsi] = "-Dplugin_scsi=true,-Dplugin_scsi=false"
100PACKAGECONFIG[plugin_synaptics_mst] = "-Dplugin_synaptics_mst=true,-Dplugin_synaptics_mst=false"
101PACKAGECONFIG[plugin_synaptics_rmi] = "-Dplugin_synaptics_rmi=true,-Dplugin_synaptics_rmi=false"
Andrew Geissler9aee5002022-03-30 16:27:02 +0000102PACKAGECONFIG[plugin_tpm] = "-Dplugin_tpm=true,-Dplugin_tpm=false,tpm2-tss"
103# Turn off the capsule splash as it needs G-I at buildtime, which isn't currently supported
104PACKAGECONFIG[plugin_uefi_capsule] = "-Dplugin_uefi_capsule=true -Dplugin_uefi_capsule_splash=false,-Dplugin_uefi_capsule=false,efivar fwupd-efi"
105PACKAGECONFIG[plugin_uefi_pk] = "-Dplugin_uefi_pk=true,-Dplugin_uefi_pk=false"
106PACKAGECONFIG[plugin_uf2] = "-Dplugin_uf2=true,-Dplugin_uf2=false"
107PACKAGECONFIG[plugin_upower] = "-Dplugin_upower=true,-Dplugin_upower=false"
108
109# Always disable these plugins on non-x86 platforms as they don't compile or are useless
Andrew Geissler87f5cff2022-09-30 13:13:31 -0500110DISABLE_NON_X86 = "plugin_amt plugin_intel_spi plugin_msr"
Andrew Geissler9aee5002022-03-30 16:27:02 +0000111DISABLE_NON_X86:x86 = ""
112DISABLE_NON_X86:x86-64 = ""
113PACKAGECONFIG:remove = "${DISABLE_NON_X86}"
114
115FILES:${PN} += "${libdir}/fwupd-plugins-* \
116 ${systemd_unitdir} \
117 ${datadir}/fish \
118 ${datadir}/metainfo \
119 ${datadir}/icons \
120 ${datadir}/dbus-1 \
121 ${datadir}/polkit-1 \
122 ${nonarch_libdir}/modules-load.d"
123
124FILES:${PN}-ptest += "${libexecdir}/installed-tests/ \
125 ${datadir}/installed-tests/"
126RDEPENDS:${PN}-ptest += "gnome-desktop-testing"