blob: 80e3cc629873ee01d01f3f384aeb5810aa7a867f [file] [log] [blame]
Andrew Geissler595f6302022-01-24 19:11:47 +00001# SPDX-FileCopyrightText: Huawei Inc.
2#
3# SPDX-License-Identifier: Apache-2.0
4
5HOMEPAGE = "https://booting.oniroproject.org/distro/components/pim435"
6SUMMARY = "A userspace driver application for PIM435 written in C"
7DESCRIPTION = "A userspace driver application for PIM435 (Pimoroni LED matrix) \
8written in C"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://LICENSES/MIT.txt;md5=7dda4e90ded66ab88b86f76169f28663"
11
Andrew Geissler87f5cff2022-09-30 13:13:31 -050012SRC_URI = "git://gitlab.eclipse.org/eclipse/oniro-blueprints/core/pim435;protocol=https;branch=main"
13SRCREV = "445ed623ec8d3ecbb1d566900b4ef3fb3031d689"
Andrew Geissler595f6302022-01-24 19:11:47 +000014S = "${WORKDIR}/git"
15
16DEPENDS = "i2c-tools"
17
18EXTRA_OEMAKE += "DESTDIR=${D}"
19
20do_install() {
21 oe_runmake install
22}