blob: f5bacfd9619eed17b4dc5e8dc37edea9bc863a06 [file] [log] [blame]
Patrick Williams92b42cb2022-09-03 06:53:57 -05001# Copyright (C) 2015 Igor Santos <igor.santos@aker.com.br>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Universal Ctags"
5DESCRIPTION = "Universal Ctags is a multilanguage reimplementation of the \
6 Unix ctags utility. Ctags generates an index of source code \
7 definitions which is used by numerous editors and utilities \
8 to instantly locate the definitions."
9
10HOMEPAGE = "https://ctags.io/"
11
12LICENSE = "GPL-2.0-only"
13LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
14
15inherit autotools-brokensep pkgconfig manpages
16
Andrew Geissler87f5cff2022-09-30 13:13:31 -050017SRCREV = "299fe525048358ecdfecb9ca91505333c0fb14f4"
Patrick Williams92b42cb2022-09-03 06:53:57 -050018SRC_URI = "git://github.com/universal-ctags/ctags;branch=master;protocol=https"
19
20S = "${WORKDIR}/git"
21
22PACKAGECONFIG ??= " \
23 readcmd \
24 xml \
25 json \
26 yaml \
27"
28PACKAGECONFIG[readcmd] = "--enable-readcmd,--disable-readcmd"
29PACKAGECONFIG[etags] = "--enable-etags,--disable-etags"
30PACKAGECONFIG[xml] = "--enable-xml,--disable-xml,libxml2"
31PACKAGECONFIG[json] = "--enable-json,--disable-json,jansson"
32PACKAGECONFIG[seccomp] = "--enable-seccomp,--disable-seccomp,libseccomp"
33PACKAGECONFIG[yaml] = "--enable-yaml,--disable-yaml,libyaml"
34PACKAGECONFIG[manpages] = ",,python3-docutils-native"