blob: 1bf6752e876daf01ffb908e9201e101337a4b614 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "libpeas is a gobject-based plugins engine"
2HOMEPAGE = "https://wiki.gnome.org/Projects/Libpeas"
3LICENSE = "LGPL-2.1-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4b54a1fd55a448865a0b32d41598759d"
5
6DEPENDS = "gtk+3"
7
8GNOMEBASEBUILDCLASS = "meson"
9GTKDOC_MESON_OPTION = "gtk_doc"
10
11inherit gnomebase gobject-introspection gtk-doc gtk-icon-cache features_check
12
13ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
14
Andrew Geissler87f5cff2022-09-30 13:13:31 -050015SRC_URI[archive.sha256sum] = "4305f715dab4b5ad3e8007daec316625e7065a94e63e25ef55eb1efb964a7bf0"
Andrew Geissler9aee5002022-03-30 16:27:02 +000016
17PACKAGECONFIG[python3] = "-Dpython3=true,-Dpython3=false,python3-pygobject"
18
19PACKAGES =+ "${PN}-demo ${PN}-python3"
20FILES:${PN}-demo = " \
21 ${bindir}/peas-demo \
22 ${libdir}/peas-demo \
23"
24
25RDEPENDS:${PN}-python3 = "python3-pygobject"
26FILES:${PN}-python3 = "${libdir}/libpeas-1.0/loaders/libpython3loader.so"