blob: 5a437c102fae9c1067bcfaf8a7730b8cfef30f19 [file] [log] [blame]
Andrew Geissler87f5cff2022-09-30 13:13:31 -05001SUMMARY = "OpenGL Mathematics Library for C"
2DESCRIPTION = "Highly optimized 2D|3D math library, also known as OpenGL Mathematics (glm) for `C`. \
3cglm provides lot of utils to help math operations to be fast and quick to write. It is community \
4friendly, feel free to bring any issues, bugs you faced."
5HOMEPAGE = "https://github.com/recp/cglm"
6BUGTRACKER = "https://github.com/recp/cglm/issues"
7SECTION = "libs"
8LICENSE = "MIT"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=8dc95c4110ba741c43832734b51b7de7"
10
11SRC_URI = "git://github.com/recp/cglm;branch=master;protocol=https"
12# Tag v0.8.5
13SRCREV = "7e5d1f435f628b873347eb052b7d6605b0b997f2"
14
15S = "${WORKDIR}/git"
16
17PACKAGECONFIG[build_tests] = "-Dbuild_tests=true,-Dbuild_tests=false,"
18
19PACKAGECONFIG ?= ""
20
21inherit meson pkgconfig
22
23EXTRA_OEMESON += "--buildtype release"
24
25BBCLASSEXTEND = "native"